# Failure in retrieving content from a backup restored collection created on a different machine

**URL:** <https://forum.weaviate.io/t/failure-in-retrieving-content-from-a-backup-restored-collection-created-on-a-different-machine/4434>\
**Category:** Support\
**Created:** [October 5, 2024, 7:25am UTC](https://forum.weaviate.io/t/failure-in-retrieving-content-from-a-backup-restored-collection-created-on-a-different-machine/4434 "2024-10-05T07:25:29Z")\
**Posts on this page:** 7\
**Page:** 1

<div class="post-metadata">

**Author:** ![kaushik\_acharya](https://yyz1.discourse-cdn.com/flex027/user_avatar/forum.weaviate.io/kaushik_acharya/32/2456_2.png) [@kaushik\_acharya](https://forum.weaviate.io/u/kaushik_acharya)\
**Post date:** [October 5, 2024, 7:25am UTC](https://forum.weaviate.io/t/failure-in-retrieving-content-from-a-backup-restored-collection-created-on-a-different-machine/4434/1 "2024-10-05T07:25:29Z")

</div>

### Description

I am running locally on my laptop the assignments from the DeepLearning.ai course: Building Multimodal Search and RAG

I am facing issue in the assignment L5 [Building Multimodal Search and RAG - DeepLearning.AI](https://learn.deeplearning.ai/courses/building-multimodal-search-and-rag/lesson/5/multimodal-rag-(mm-rag)).  
In this assignment we load the backup collection (containing images and videos) provided in the course:

> client.backup.restore(  
> backup\_id=“resources-img-and-vid”,  
> include\_collections=collection\_name,  
> backend=“filesystem”  
> )

I am able to get the count of images and videos.

The error comes while retrieving similar content based on a text query. (This is a multimodal assignment where we do retrieve images and videos based on text query).

> resources = client.collections.get(collection\_name)  
> response = resources.query.near\_text(  
> query=query,  
> filters=Filter.by\_property(“mediaType”).equal(“image”), # return only image objects  
> return\_properties=[“path”],  
> limit=1  
> )

Error stack:

`python3.11/site-packages/weaviate/collections/grpc/query.py:618) raise WeaviateQueryError(e.details(), "GRPC search") WeaviateQueryError: Query call with protocol GRPC search failed with message explorer: get class: vectorize params: vectorize params: vectorize params: vectorize keywords: remote client vectorize: connection to Google PaLM failed with status: 403 error: Permission 'aiplatform.endpoints.predict' denied on resource '//aiplatform.googleapis.com/projects/semi-random-dev/locations/us-central1/publishers/google/models/multimodalembedding@001' (or it may not exist)..`

**My understanding for the reason of this failure** :

The collection was likely created using the below command as mentioned in L2 assignment: [Building Multimodal Search and RAG - DeepLearning.AI](https://learn.deeplearning.ai/courses/building-multimodal-search-and-rag/lesson/3/multimodal-search)

```auto
client.collections.create(
    name=collection_name,
    vectorizer_config=Configure.Vectorizer.multi2vec_palm(
        image_fields=["image"],
        video_fields=["video"],
        project_id="semi-random-dev",
        location="us-central1",
        model_id="multimodalembedding@001",
        dimensions=1408
    )
)

```

The project\_id mentioned is **semi-random-dev**. Whereas the project\_id of my project in Google Cloud is different.

**Question** : Is it possible to change the project\_id in the vectorizer\_config of the restored collection?

### Server Setup Information

- Weaviate Server Version: weaviate-client==4.5.4
- Deployment Method: embedded
- Multi Node? Number of Running Nodes:
- Client Language and Version: Python 3.11
- Multitenancy?:

### Any additional Information

---

<div class="post-metadata">

**Author:** ![DudaNogueira](https://yyz1.discourse-cdn.com/flex027/user_avatar/forum.weaviate.io/dudanogueira/32/7846_2.png) [@DudaNogueira](https://forum.weaviate.io/u/DudaNogueira)\
**Post date:** [October 6, 2024, 5:49pm UTC](https://forum.weaviate.io/t/failure-in-retrieving-content-from-a-backup-restored-collection-created-on-a-different-machine/4434/2 "2024-10-06T17:49:40Z")

</div>

hi @kaushik_acharya !!

Welcome to our community 🤗

It looks like it is indeed what you mentioned.

You may need to create the collection with the project name you have access to.

Unfortunately, those infos are not mutable ([check here for a list of mutability configs of a collection](https://weaviate.io/developers/weaviate/config-refs/schema#mutability)).

What you can do, in order to change immutable configs of a collection is to reindex your data using our [migration guide](https://weaviate.io/developers/weaviate/manage-data/migrate).

Let me know if this helps!

---

<div class="post-metadata">

**Author:** ![kaushik\_acharya](https://yyz1.discourse-cdn.com/flex027/user_avatar/forum.weaviate.io/kaushik_acharya/32/2456_2.png) [@kaushik\_acharya](https://forum.weaviate.io/u/kaushik_acharya)\
**Post date:** [October 13, 2024, 1:52pm UTC](https://forum.weaviate.io/t/failure-in-retrieving-content-from-a-backup-restored-collection-created-on-a-different-machine/4434/3 "2024-10-13T13:52:22Z")

</div>

Hi @DudaNogueira  
First of all thanks for the reply.

I am facing issue similar to the one mentioned in [Embedded Weaviate Port 6060 - Support - Weaviate Community Forum](https://forum.weaviate.io/t/embedded-weaviate-port-6060/799)

As mentioned in the above thread, I added the environment variable:  
`"GO_PROFILING_DISABLE": "true"`  
in `weaviate.connect_to_embedded`  
which gives the message:  
`listen tcp :6060: bind: address already in use`  
and throws the error

> WeaviateStartUpError: Embedded DB did not start listening on port 8090 within 30 seconds

I have passed a different `port` and `grpc_port` for the target weaviate instance.

---

<div class="post-metadata">

**Author:** ![DudaNogueira](https://yyz1.discourse-cdn.com/flex027/user_avatar/forum.weaviate.io/dudanogueira/32/7846_2.png) [@DudaNogueira](https://forum.weaviate.io/u/DudaNogueira)\
**Post date:** [October 14, 2024, 11:10pm UTC](https://forum.weaviate.io/t/failure-in-retrieving-content-from-a-backup-restored-collection-created-on-a-different-machine/4434/4 "2024-10-14T23:10:14Z")

</div>

hi! There is probably something running also on port 6060, so Weaviate embedded was not able to start.

Also, try using a new client version.

---

<div class="post-metadata">

**Author:** ![kaushik\_acharya](https://yyz1.discourse-cdn.com/flex027/user_avatar/forum.weaviate.io/kaushik_acharya/32/2456_2.png) [@kaushik\_acharya](https://forum.weaviate.io/u/kaushik_acharya)\
**Post date:** [October 15, 2024, 7:57pm UTC](https://forum.weaviate.io/t/failure-in-retrieving-content-from-a-backup-restored-collection-created-on-a-different-machine/4434/5 "2024-10-15T19:57:32Z")

</div>

The command `lsof -i:6060` shows

```auto
COMMAND PID USER FD TYPE DEVICE SIZE/OFF NODE NAME
weaviate- 12670 kaushik 8u IPv6 3175934 0t0 TCP *:6060 (LISTEN)

```

---

<div class="post-metadata">

**Author:** ![DudaNogueira](https://yyz1.discourse-cdn.com/flex027/user_avatar/forum.weaviate.io/dudanogueira/32/7846_2.png) [@DudaNogueira](https://forum.weaviate.io/u/DudaNogueira)\
**Post date:** [October 16, 2024, 2:30am UTC](https://forum.weaviate.io/t/failure-in-retrieving-content-from-a-backup-restored-collection-created-on-a-different-machine/4434/6 "2024-10-16T02:30:00Z")

</div>

Yes, this is probably some conflict on embedded running on port 6060 for profiling.

Can you try moving away from embedded? This is only meant to allow a quick run on Weaviate directly from the client.

you can copy over your data from the Embedded Weaviate path to the same path at `PERSISTENCE_DATA_PATH` at a docker instance for example.

Also, have you tried running on a newer client?

Thanks!

---

<div class="post-metadata">

**Author:** ![kaushik\_acharya](https://yyz1.discourse-cdn.com/flex027/user_avatar/forum.weaviate.io/kaushik_acharya/32/2456_2.png) [@kaushik\_acharya](https://forum.weaviate.io/u/kaushik_acharya)\
**Post date:** [October 26, 2024, 10:20am UTC](https://forum.weaviate.io/t/failure-in-retrieving-content-from-a-backup-restored-collection-created-on-a-different-machine/4434/7 "2024-10-26T10:20:04Z")

</div>

Using weaviate client version 4.9.0 on embedded also throws the same error:

> WeaviateStartUpError: Embedded DB did not start listening on port 8090 within 30 seconds

Only difference is the newer client version is not showing the message

> listen tcp :6060: bind: address already in use

I didn’t tried docker instance as suggested by you.
