# Weaviate migrate to 1.24: start service error

**URL:** https://forum.weaviate.io/t/weaviate-migrate-to-1-24-start-service-error/1729
**Category:** Support
**Created:** [March 15, 2024, 3:58pm UTC](https://forum.weaviate.io/t/weaviate-migrate-to-1-24-start-service-error/1729 "2024-03-15T15:58:14Z")
**Posts on this page:** 3
**Page:** 1

<div class="post-metadata">

### Author: ![garance](https://avatars.discourse-cdn.com/v4/letter/g/c2a13f/32.png) [@garance](https://forum.weaviate.io/u/garance)
#### Post date: [March 15, 2024, 3:58pm UTC](https://forum.weaviate.io/t/weaviate-migrate-to-1-24-start-service-error/1729/1 "2024-03-15T15:58:14Z")

</div>

Hi, I tried to migrate Weaviate 1.22.11 to 1.24.0, Weaviate is on AWS ECS. When I started the service, I got the error:

```auto
 "error": "init shard \"test_X6mCkorqyK9u\": init shard \"test_X6mCkorqyK9u\": init per property indices: init properties on shard 'test_X6mCkorqyK9u': create property 'document_type' value index on shard 'test_X6mCkorqyK9u': init disk segments: invalid compacted segment file name \"segment-1709661156235385913.db.tmp\"",
    "level": "error",
    "msg": "Unable to load shard X6mCkorqyK9u: init shard \"test_X6mCkorqyK9u\": init shard \"test_X6mCkorqyK9u\": init per property indices: init properties on shard 'test_X6mCkorqyK9u': create property 'document_type' value index on shard 'test_X6mCkorqyK9u': init disk segments: invalid compacted segment file name \"segment-1709661156235385913.db.tmp\""

```

Weaviate service can’t be started.

How could I do? Should I return to old version and delete my class, or there is a better solution? Thanks.

---

<div class="post-metadata">

### Author: ![DudaNogueira](https://yyz1.discourse-cdn.com/flex027/user_avatar/forum.weaviate.io/dudanogueira/32/7846_2.png) [@DudaNogueira](https://forum.weaviate.io/u/DudaNogueira)
#### Post date: [March 15, 2024, 7:11pm UTC](https://forum.weaviate.io/t/weaviate-migrate-to-1-24-start-service-error/1729/2 "2024-03-15T19:11:07Z")

</div>

Hi!

I believe this is a similar error:

> [@Startup Failure](https://forum.weaviate.io/t/startup-failure/1709/6):
>
> Hi @msj242, this error init segment segment-1705570724834516877.db: mmap file: invalid argument" may be caused by a corrupted .db file, it could be due to a reboot or unexpected crash (also during compaction) when using a version lower than v1.24 where integrity of files was improved. Was that data created in an older version?

---

<div class="post-metadata">

### Author: ![jeronimo\_irazabal](https://yyz1.discourse-cdn.com/flex027/user_avatar/forum.weaviate.io/jeronimo_irazabal/32/991_2.png) [@jeronimo\_irazabal](https://forum.weaviate.io/u/jeronimo_irazabal)
#### Post date: [March 15, 2024, 7:57pm UTC](https://forum.weaviate.io/t/weaviate-migrate-to-1-24-start-service-error/1729/3 "2024-03-15T19:57:39Z")

</div>

In this case it’s due to the existence of temporary files during, those were not handled before 1.24, but those files could be deleted before upgrading to 1.24 (it’s recommendable to still do a backup of those files anyways).
