422 error no backup backend s3

I’m currently facing an issue with Weaviate while attempting to perform a backup to an S3 bucket. I receive the following error code when attempting to create a backup to an s3 bucket: “Unexpected status code: 422, with response body: {‘error’: [{‘message’: 'no backup backend “s3”: backup: s3 not found, did you enable the right module?”.
This is despite including ‘ENABLE_MODULES=backup-s3’ & ‘BACKUP_S3_BUCKET=bucket_name’ in my .env and docker-compose.yml config.

Here is my code:

Any help is appreciated.

Are you sure that you have enabled this module?

If you have this module enabled then it should be in the /meta response. Can you verify this?

meta_info = client.get_meta()

It doesn’t appear in meta_info, I am loading ‘ENABLE_MODULES’ from .env. Can the module be passed as an additional header?

Ok, so you don’t have it enabled. You need to update your ENABLE_MODULES and add backup-s3 module env setting in your environment, where you have your Weaviate deployed, this will resolve your problem then.

docker yaml:
However I still receive 422 error. I am using weaviate-client==3.21.0

Can you post the full docker-compose.yaml (or alternatively Helm values.yaml)? There must be a mistake in there somewhere. It seems ENABLE_MODULES is not correctly propagated to the server.

the issue has been resolved.

hey, what was your solution?