Rebuilding weaviate docker image


I am facing an issue with azure openai access. I want to change the URL used but it’s hardcoded in weaviate.

So I tried to change it in the source code, however i have not been able to run weaviate from the source. Everything in the installation documentation (unless I missed it) relies on downloading existing docker images.

I tried to rebuild the docker image but could not find the Dockerfile. There is a Dockerfile provided but it seems to build a large number of images, but not weaviate.

Could anyone help me just how to find the proper Dockerfile to build semitechnologies/weaviate:1.22.3 from source? Thanks a lot.



Have you seen this new feature?

X-OpenAI-BaseURL - Available from version v1.22.3 Use the protocol domain format: . If specified, this will have precedence over the class-level setting.

It was added recently with this PR: Add possibility to pass OpenAI BaseURL value using HTTP header by antas-marcin · Pull Request #3737 · weaviate/weaviate · GitHub

Let me know if that helps!