Verba: Something went wrong: 'NoneType' object is not iterable

Description

I installed Verba on Docker today using the latest version. The installation went smoothly. However, when I accessed Verba at localhost:8000 , the homepage loaded correctly. I tried to make an initial request by sending “hi” in the chat, but I encountered an error message in red below the chat window: “Something went wrong: ‘NoneType’ object is not iterable.” Additionally, the message “Retrieving chunks” keeps spinning without displaying any content.
After i tried to add a document i swaped to OllamaEmbeder to make it work and tried again a question and got the same error.

Server Setup Information

  • Weaviate Server Version: ‘3.4’
  • Deployment Method: docker/Ollama
  • Multi Node? Number of Running Nodes: 1
  • Client Language and Version: /

Any additional Information

Followed the classic guide for docker on the github.

Hi! Do you see any outstanding logs?

Also, did you see a success message after importing documents?

Hey,

I believe the issue was with Verba, as it appeared on the Verba (weaviate.io) platform this morning for a bit. I deleted everything, re-downloaded it, and now the problem is resolved.

1 Like

Awesome!

Thanks for sharing!

Hello, I deleted Verba and reinstalled it but am still getting the same issue. Could there be other reasons as to why this occurring/other ways to fix the issue?

Hi @mchu249 !! Welcome to our community :hugs:

Are you running Weaviate embedded? Don’t forget to delete also the data path (Verba defaults to using docker volume named weaviate_data), otherwise, reinstalling Verba alone may not be enough.

I was never able to reproduce this error. Can you get more details on that?

Thanks!

Hello, I am not sure if I am running Weaviate embedded. How do I verify this? My apologies, I am new to Weaviate and Docker. And by deleting the data path, is commenting out the volume setup in the docker-compose.yml file sufficient?

In terms of the NoneType error, I did not do anything different from the installation instructions on Github for Verba and Docker. The only changes I made to the code before running it were in the docker-compose file and the .env file which I created. I’ve attached images of the changes.

image

image

As you are using from Docker, you are using Weaviate on a container.

if you install verba locally, as a python package, then it will use the Embedded.

Let me know if you are willing to connect as I would like to see this error up close.

Otherwise it is hard to identify.

Feel free to ping me in slack. Thanks!

1 Like

I’m also having the same issue here but I’m using Google Gemini model. @DudaNogueira Can you please help us out here? Thanks!
I’m willing to connect to solve this.

hi @dean_vidic !

I have just debugged that with @mchu249 today :joy:

Are you running on Docker Desktop over windows by any chance?

We were able to identify, inspecting the network info at the dev console on a chrome browser that the UI is not able to open the websocket for some reason at /ws/generate_stream.

This is what I see on a working Verba running on docker on a mac:

So whenever you send a question on the chatbox, the changes need to flow from that websocket in network tab. and also note the connection opened at the console.

My gut feeling is that this could be something windows itself :thinking:

I’m running this on Windows indeed using Docker. So you think it’s Win related… Ok, let’s call it a day and use some other RAG solution. What’s interesting here is that it only works with OpenAI key. I tried to use Gemini pro but I keep getting that ‘NoneType’ error.

Actually it says ‘websocket online’ just below chat window when I run it. I managed to start it without Docker using WEAVIATE_URL_VERBA and WEAVIATE_API_KEY_VERBA. Let me know if you can help me out here to actually start using this thing.

Hi!

Can you see messages flowing thru the websocket when a query is sent from the UI?

@dean_vidic Note that Verba is a demo project, and no a product. At least tet :speak_no_evil:

If you want to get your hands dirty, you can explore other routes, even having full control over the ingestion and RAG generation.

Here for example is a recipe I wrote that allows you to query Weaviate directly and thru langchain. It alse uses Langchain for doing the chunking of PDF documents:

Based on that recipe, you can add more features, like ingesting from all files in a directory and more:

For example, Weaviate will work with Gemini:

And Verba also has this option exposed:

Let me know if this helps!

Thanks!

Ok, thanks. I have to figure out all this, it’ll take some time. Keep in touch.

1 Like