Verba stuck with older informations

I have a small problem with Verba, and thought of bringing it here.
I have changed the number of searchable documents to 40000- I know that the maximum is 10000 and everything beyond that might make the process very slow. Hopefully we have a powerful station.

We did this, because the same documents come up all the time and the search function fails to bring the more relevant ones, even when I explicitly mention in the prompt non-ambiguous elements such as names, or journal titles, that would appear only in the newly uploaded documents.

It feels that my Verba is somehow stuck in an early stage of embedding and would refuse to bring up many of the latest uploaded documents (I tried to reupload them only to discover that they are already there).

Any ideas what might be wrong? Would be a way to reshuffle the assets?

hi @Ilan_Manouach !

Can you make sure the new objects are indeed indexed?

Also, could you do a query directly to Weaviate and check if the results can be found with the same query?

With that we can isolate the issue and maybe understand what is happening.


Hi @DudaNogueira !

Thank you for your swift response.
Actually they don’t seem to be indexed. When I am trying to upload them, I am getting an immediate “already exists” message but they will not show up in the “Documents” section of Verba.

I am confused. If they already exist this should mean that they are already indexed? Or not necessarily?

Unfortunately, querying directly Weaviate goes beyond my current skill set. I tried to prompt Verba but I see that it requires a Graph API for that.

How have you deployed Verba?

This can give me a hint on your to guide you into connecting directly to Verba.


hi @DudaNogueira
We are running it locally through docker compose.