Weaviate High Usage of CPU

Hi Guys
We use weaviate with docker image and we experience high CPU usage even when stale can any one suggest any methods to limit it?

Thanks
Sam

Hi! Welcome to our community :hugs:

How many objects do you have in your index? Also, do you see any outstanding logs?

One way of limit cpu usage is definig those limit on the upper layer. In you case, using docker.

Let me know if that helps.

Thanks!

Hi Duda,

we are also experiencing similar kind of issue.
How does it work in case we have a high number of object but all the vectors are currently set to None, even in this case memory and cpu usage are so high and it get out of memory.

Thanks,
Saurabh

Hi @Saurabh ! Welcome to our community :hugs:

So you are not providing your own vectors, and doesn’t have a vectorizer configured for the class, right?

Weaviate will consume a lot of CPU while ingesting data, as it needs to build up both the vector and the inverted index for performing searches.

If you do not have vectors, the memory consumption should be lower.

How many objects are you ingesting? Do you see any outstanding logs?

I am also getting the same issue and I shared the stats . I have only 10k objects present inside 2 schema and don’t get any logs regarding this

What are the version you are running @Dharanish ?

Also, is there a public dataset we can test this on?

We are running this in v1.21.2 and we don’t use any public dataset and also no vectorizer module

@Dharanish,

According to here:

There is an option, LIMIT_RESOURCES, where you can force Weaviate to do not use all resources.

This is probably the reason it is consuming all the allocated resources.

Let me know if this helps.