Weaviate Helm Chart Failing

Hello All,
We have a Weaviate installation on our openshift cluster, which was running fine just a few days back. While from yesterday it went into crash loopback off state with below error

{“action”:“startup”,“default_vectorizer_module”:“none”,“level”:“info”,“msg”:“the default vectorizer modules is set to "none", as a result all new schema classes without an explicit vectorizer setting, will use this vectorizer”,“time”:“2024-03-26T07:17:50Z”}
{“action”:“startup”,“auto_schema_enabled”:true,“level”:“info”,“msg”:“auto schema enabled setting is set to "true"”,“time”:“2024-03-26T07:17:50Z”}
{“action”:“memberlist_init”,“bind_port”:7000,“error”:“Failed to get final advertise address: No private IP address found, and explicit IP not provided”,“hostname”:“”,“level”:“error”,“msg”:“memberlist not created”,“time”:“2024-03-26T07:17:50Z”}
{“action”:“startup”,“error”:“create member list: Failed to get final advertise address: No private IP address found, and explicit IP not provided”,“level”:“error”,“msg”:“could not init cluster state”,“time”:“2024-03-26T07:17:50Z”}

Even if we try to redeploy, it doesn’t run anymore.

Radha M De

Hello Team
Do you have any suggestions to resolve this problem?

Hi! @Radha_Mohan_De

What is the version you are running?

This may be something related to your k8s, following this thread:

Let me know if this helps.

Hi Duda
We are trying to install Weaviate Helm Chart 16.5.0 (which is for Weaviate 1.21.0).
In this link, the same error is being discussed and they are asking to set a valid pod subnet. Hope that is to be set in cluster level, right?

BTW, other containers are running fine, except this weaviate, which was also running earlier, but stopped running from yesterday suddenly. But the cluster team says they have not changed anything in cluster.

One more point, when we try to query podCIDR in node level for openshift cluster, we find null for those, by following command. Is it the root cause?

oc get no -o json | jq ‘.spec.podCIDRs’

Radha M De

@DudaNogueira - Is there any update on the issue that we are seeing with respect to Weaviate pod

We are still seeing the same error as mentioned above. The versions currently being used are as below. We have a Openshift cluster hosted in Azure cloud environment

$ oc version
Client Version: 4.10.35
Server Version: 4.10.57
Kubernetes Version: v1.23.17+16bcd69

Please let me know if its related to the Openshift or Kubernetes versions.


Hi! We have seen some other issues related to this, but they are usually related to the environment.

I have forwarded this internally, and we’ll take a closer look on this soon.