No bucket for prop '<my_property>' null found"- issue with indexNullState?

hi, I recently rebuilt my class with “indexNullState”: true. I also have autoschema enabled. When reloading my data, I am getting sporadic error:
“update inverted indices: put inverted indices props: add indexed null state: no bucket for prop ‘<my_property>’ null found”.
This is occurring for properties that I haven’t manually defined. However, when I tried adding a new object with some random properties, I did not get this error on those new properties, so I’m having trouble reproducing/figuring out what the root issue is. If anyone has run into this and can point me in the right direction I’d really appreciate it!

Hi @mjsteele !

Welcome to our community :hugs:

Reproducing this on a python notebook is usually the ideal.

Did you create your properties before importing, during the class creation, or using the auto schema feature?

I will poke internally about this.

Thanks for reporting!

Hi Duda,

Apologies for not having a notebook, I’m struggling to recreate the error with synthetic data. To your question:

  1. I created some properties during class creation (none of these properties are throwing the error when importing objects)
  2. All the properties that are throwing the error were not created during class creation, but rather were created with auto schema when doing batch importing.
  3. I have tried recreating the error by batch uploading new objects with a few new properties, but I’m not getting the error.
  4. If it helps at all, in my pipeline I’m batch importing when I have >1000 objects to insert