Unable to restore data


I am trying to restore data created in a weaviate outside the network of my organisation and trying to restore it to our on-premise weaviate. The restore command gives success status but I can see only the class is created but there is no data in it.

Server Setup Information

  • Weaviate Server Version: 1.23 Destination, 1.23.3 Source
  • Deployment Method: k8s Destination, Docker Source
  • Multi Node? Number of Running Nodes: 1
  • Client Language and Version: python 3

Hi! are both the server version the same?

Do you see any outstanding errors in logs?

The Weaviate Server Versions are 1.23.0 Destination and 1.23.3 Source. I will check the logs but I did get the success status.

They must be the same versions, AFAIK

I tried to load data in another weaviate with the same version as my organization (1.23.0) but in a public network and I was able to do it. Not sure if there is a network call that goes out as part of the restore activity that gets blocked in my organization’s network.

hi @bedirachit !

It shouldn’t have any different calls from the ones used to query data, for example.

But as changing the network factor solved, that was probably the issue factor.

Glad you solved it.

Thanks for sharing!